2011年11月11日 星期五

brew install s3fs Requested 'fuse >= 2.8.4' but version of fuse is 2.7.3

If you installing s3fs via brew in your mac book pro and you see this "Requested 'fuse >= 2.8.4' but version of fuse is 2.7.3".

please remove fuse4x & fuse4x-kext 
brew -f uninstall fuse4x fuse4x-kext
download fuse4x from http://fuse4x.org/ and install it
then brew install s3fs should be works

thanks for chunghe troubleshooting!

2 則留言:

  1. Hi, this sounds wrong to me. Version of fuse4x both in Homebrew and in binary package (*.dmg file) is the same - 2.8.4

    I think that the system was screwed because you previously had either macfuse or osxfuse (they have ancient version of libfuse). Please uninstall macfuse first, see this ticket https://github.com/fuse4x/fuse4x/issues/18#issuecomment-3134531

    回覆刪除
  2. it's a little to hard to me so I am changed to used s3cmd for sync all file & directorys.

    thanks for remind anyways :)

    回覆刪除